Trad Talk Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1,682 Posts
Discussion Starter · #1 ·
I mounted my TT RC Wood limbs on my new 25" riser and when I drew back at a certain point, there was a creaking sound coming from the limb pocket... which I figured out was the spring detent pin/spring. After removing the limb and pressing the detent pin in and out, it definitely was a little creaky.

So undid the ILF fitting bolt and put a little grease (only had some light graphite grease on hand) on the spring and reassembled. Problem solved!
This is the first time I've ever needed to do this, but I do recall it being mentioned here so in case anyone encounters this issue, you will know what to do!
 

·
Premium Member
Joined
·
12,829 Posts
I've had some pesky ones that would not fix no matter what I lubed them with, so I ran them empty.......pin & springs never seemed important to me.
I have had some riser & limb fitting combinations that were not smooth at all, full of nicks that would catch on each other, MAKING NOISE.
this juncture where they meet needs to be SMOOTH, as things move minutely, during drawing & release.
I smoothed them both up JUST a little with emory tape, and lubed them both to slide well.......never a problem after that.
 

·
Premium Member
Joined
·
2,299 Posts
Daniel,

You sure it's the pin? I've experienced a creaking sound a time or two but only when I had the limbs backed off too far. Come to find out it was the fitting fouling in the slot. I tightened them up a full turn and it stopped.
 
  • Like
Reactions: Coodster

·
Registered
Joined
·
1,682 Posts
Discussion Starter · #10 ·
Daniel,

You sure it's the pin? I've experienced a creaking sound a time or two but only when I had the limbs backed off too far. Come to find out it was the fitting fouling in the slot. I tightened them up a full turn and it stopped.
The bolts are a couple of turns out... I'm pretty sure its the pins because if I press down the limb while strung, I can hear the spring/pin creak.
Then again I won't assume anything since it's my first time encountering this (and I had these limbs sitting on my shelf for a while so first time using them too.)
 

·
Registered
Joined
·
1,682 Posts
Discussion Starter · #12 ·
Well it just goes to show - never assume anything! I removed the pin and spring, and the creak was still there!
Turns out it was the dovetail slot... I put a bit of string wax on the limb dovetail and problem solved. Not sure why it was creaking it the first place, but now its silent as it should be.

Thanks everyone for the insights!
 
1 - 12 of 12 Posts
Top